Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

mayavi [2017/08/25 09:56] (Version actuelle)
Ligne 1: Ligne 1:
 +**Mayavi**
  
 +====== Installation ======
 +<Code>
 +[henry@holopherne ~]$ virtualenv --no-site-packages temp
 +New python executable in temp/bin/python
 +Installing Setuptools..............................................................................................................................................................................................................................done.
 +Installing Pip.....................................................................................................................................................................................................................................................................................................................................done.
 +[henry@holopherne ~]$ cd temp
 +[henry@holopherne ~/temp]$ source bin/activate
 +Badly placed ()'s.
 +[henry@holopherne ~/temp]$ mkdir temp_subdir
 +[henry@holopherne ~/temp]$ easy_install -zmaxd temp_subdir "Mayavi[app,nonets]"
 +Searching for Mayavi[app,nonets]
 +Reading https://pypi.python.org/simple/Mayavi/
 +Best match: mayavi 4.4.3
 +Downloading https://pypi.python.org/packages/source/m/mayavi/mayavi-4.4.3.zip#md5=5241d46886c1dbadd96f3b19710102dc
 +Processing mayavi-4.4.3.zip
 +Writing /tmp/easy_install-TP8Rw3/mayavi-4.4.3/setup.cfg
 +Running mayavi-4.4.3/setup.py -q bdist_egg --dist-dir /tmp/easy_install-TP8Rw3/mayavi-4.4.3/egg-dist-tmp-D_rJIT
 +no previously-included directories found matching 'docs/build'
 +no previously-included directories found matching 'docs/pdf'
 +In file included from /usr/lib64/python2.7/site-packages/numpy/core/include/numpy/ndarraytypes.h:1728:0,
 +                 from /usr/lib64/python2.7/site-packages/numpy/core/include/numpy/ndarrayobject.h:17,
 +                 from /usr/lib64/python2.7/site-packages/numpy/core/include/numpy/arrayobject.h:15,
 +                 from tvtk/src/array_ext.c:223:
 +/usr/lib64/python2.7/site-packages/numpy/core/include/numpy/npy_deprecated_api.h:11:2: warning: #warning "Using deprecated NumPy API, disable it by #defining NPY_NO_DEPRECATED_API NPY_1_7_API_VERSION" [-Wcpp]
 + #warning "Using deprecated NumPy API, disable it by #defining NPY_NO_DEPRECATED_API NPY_1_7_API_VERSION"
 +  ^
 +----------------------------------------------------------------------
 +Building TVTK classes... vtkIncrementalForceLayout: Ignoring method: Get/SetGravityPoint
 +default: [200.0, 200.0], range: None
 +vtkOpenGLExtensionManager IgnoreDriverBugs
 +vtkChartMatrix: Ignoring method: Get/SetGutter
 +default: [15.0, 15.0], range: None
 +vtkChartMatrix: Ignoring method: Get/SetSize
 +default: [0, 0], range: None
 +vtkSimple3DCirclesStrategy: Ignoring method: Get/SetMarkedValue
 +default: (invalid), range: None
 +vtkArrayNorm: Ignoring method: Get/SetWindow
 +default: [0, 9223372036854775807), range: None
 +vtkChart: Ignoring method: Get/SetSize
 +default: [0.0, 0.0, 0.0, 0.0], range: None
 +vtkChartXYZ: Ignoring method: Get/SetAxisColor
 +default: [0, 0, 0, 255], range: None
 +vtkPLYWriter color is not updateable
 +vtkPlot: Ignoring method: Get/SetShiftScale
 +default: [0.0, 0.0, 1.0, 1.0], range: None
 +vtkScatterPlotMatrix: Ignoring method: Get/SetScatterPlotSelectedActiveColor
 +default: [0, 204, 0, 102], range: None
 +vtkScatterPlotMatrix: Ignoring method: Get/SetScatterPlotSelectedRowColumnColor
 +default: [204, 0, 0, 102], range: None
 +vtkScatterPlotMatrix: Ignoring method: Get/SetActivePlot
 +default: [0, 0], range: None
 +vtkSparseArray_I10vtkVariantE: Ignoring method: Get/SetExtents
 +default: , range: None
 +vtkSparseArray_I10vtkVariantE: Ignoring method: Get/SetNullValue
 +default: (invalid), range: None
 +vtkSparseArray_I12vtkStdStringE: Ignoring method: Get/SetExtents
 +default: , range: None
 +vtkSparseArray_I16vtkUnicodeStringE: Ignoring method: Get/SetExtents
 +default: , range: None
 +vtkSparseArray_IaE: Ignoring method: Get/SetExtents
 +default: , range: None
 +vtkSparseArray_IcE: Ignoring method: Get/SetExtents
 +default: , range: None
 +vtkSparseArray_IdE: Ignoring method: Get/SetExtents
 +default: , range: None
 +vtkSparseArray_IfE: Ignoring method: Get/SetExtents
 +default: , range: None
 +vtkSparseArray_IhE: Ignoring method: Get/SetExtents
 +default: , range: None
 +vtkSparseArray_IiE: Ignoring method: Get/SetExtents
 +default: , range: None
 +vtkSparseArray_IjE: Ignoring method: Get/SetExtents
 +default: , range: None
 +vtkSparseArray_IlE: Ignoring method: Get/SetExtents
 +default: , range: None
 +vtkSparseArray_ImE: Ignoring method: Get/SetExtents
 +default: , range: None
 +vtkSparseArray_IsE: Ignoring method: Get/SetExtents
 +default: , range: None
 +vtkSparseArray_ItE: Ignoring method: Get/SetExtents
 +default: , range: None
 +vtkSparseArray_IxE: Ignoring method: Get/SetExtents
 +default: , range: None
 +vtkSparseArray_IyE: Ignoring method: Get/SetExtents
 +default: , range: None
 +vtkThresholdTable: Ignoring method: Get/SetMaxValue
 +default: 2147483647, range: None
 +vtkThresholdTable: Ignoring method: Get/SetMinValue
 +default: 0, range: None
 +vtkColorLegend: Ignoring method: Get/SetPosition
 +default: [0.0, 0.0, 0.0, 0.0], range: None
 +vtkPlotHistogram2D: Ignoring method: Get/SetPosition
 +default: [1.8759341123043108e+28, 1.1866763899305888e+27, 3.8115318229635024e-43, 0.0], range: None
 +vtkMoleculeMapper bond_color is not updateable
 +Done.
 +----------------------------------------------------------------------
 +
 +Installed /home/henry/temp/temp_subdir/mayavi-4.4.3-py2.7-linux-x86_64.egg
 +
 +Because this distribution was installed --multi-version, before you can
 +import modules from this package in an application, you will need to
 +'import pkg_resources' and then use a 'require()' call similar to one of
 +these examples, in order to select the desired version:
 +
 +    pkg_resources.require("mayavi" # latest installed version
 +    pkg_resources.require("mayavi==4.4.3" # this exact version
 +    pkg_resources.require("mayavi>=4.4.3" # this version or higher
 +
 +
 +Note also that the installation directory must be on sys.path at runtime for
 +this to work.  (e.g. by being the application's script directory, by being on
 +PYTHONPATH, or by being added to sys.path by your code.)
 +
 +Processing dependencies for Mayavi[app,nonets]
 +Traceback (most recent call last):
 +  File "/bin/easy_install", line 9, in <module>
 +    load_entry_point('setuptools==0.9.8', 'console_scripts', 'easy_install')()
 +  File "/usr/lib/python2.7/site-packages/setuptools/command/easy_install.py", line 1992, in main
 +    with_ei_usage(lambda:
 +  File "/usr/lib/python2.7/site-packages/setuptools/command/easy_install.py", line 1979, in with_ei_usage
 +    return f()
 +  File "/usr/lib/python2.7/site-packages/setuptools/command/easy_install.py", line 1996, in <lambda>
 +    distclass=DistributionWithoutHelpCommands, **kw
 +  File "/usr/lib64/python2.7/distutils/core.py", line 152, in setup
 +    dist.run_commands()
 +  File "/usr/lib64/python2.7/distutils/dist.py", line 953, in run_commands
 +    self.run_command(cmd)
 +  File "/usr/lib64/python2.7/distutils/dist.py", line 972, in run_command
 +    cmd_obj.run()
 +  File "/usr/lib/python2.7/site-packages/setuptools/command/easy_install.py", line 380, in run
 +    self.easy_install(spec, not self.no_deps)
 +  File "/usr/lib/python2.7/site-packages/setuptools/command/easy_install.py", line 623, in easy_install
 +    return self.install_item(spec, dist.location, tmpdir, deps)
 +  File "/usr/lib/python2.7/site-packages/setuptools/command/easy_install.py", line 655, in install_item
 +    self.process_distribution(spec, dist, deps)
 +  File "/usr/lib/python2.7/site-packages/setuptools/command/easy_install.py", line 706, in process_distribution
 +    [requirement], self.local_index, self.easy_install
 +  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 631, in resolve
 +    requirements.extend(dist.requires(req.extras)[::-1])
 +  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2497, in requires
 +    "%s has no such extra feature %r" % (self, ext)
 +pkg_resources.UnknownExtra: mayavi 4.4.3 has no such extra feature 'nonets'
 +/usr/lib64/python2.7/site-packages/numpy/distutils/misc_util.py:252: RuntimeWarning: Parent module 'numpy.distutils' not found while handling absolute import
 +  from numpy.distutils import log
 +</Code>